Caractères spéciaux



  • Bonjour,
    Il arrive que les "caractères spéciaux" ( citations, gras, souligné, .. ) ne s'affichent pas .
    S'agit-il d'une fausse maneuvre de ma part ?
    Comment y remédier ?
    Merci d'avance.


  • Modérateurs

    Salut,

    En effet, je n'ai pas encore réglé tous les bugs d'affichage. Le bug que nous avons identifié vient du symbole inférieur < qui a tendance à faire foirer les BBcode qui suivent ou pire quand il est mis entre balises tex.

    La solution consiste probablement à interdire l'usage des balises html pour les remplacer toutes par du BBcode : sup sub center. Il faudra aussi revoir certains posts comme celui-ci qui utilisent d'autres balises html. Ainsi les symboles < pourront être interprétés comme des caractères et non des débuts de balises.

    En attendant que je m'attelle à la tâche, on peut utiliser ce fil pour lister les bugs d'affichage. Cela m'aidera à mieux les identifier et les comprendre ... J'en ai vu un passer dernièrement mais je ne remets pas la main dessus ....



  • OK
    Le problème est que cela se produit parfois, mais pas systématiquement.
    Bon courage.



  • Bonjour,

    Un détail concernant la couleur d’une partie de texte.

    Je sélectionne "
    une partie d’un texte en couleur" je choisis bleu.
    Je sélectionne " autre partie de la même couleur " en cliquant sur bleu, ça n’a plus d’effet.

    En choisissant une nouvelle couleur, ça marche :

    Je sélectionne "
    autre partie de la même couleur" en cliquant sur rouge, c'est ok.

    En remplaçant manuellement "red" par "blue" dans la balise, parfois le texte redevient noir, parfois prend en compte la nouvelle couleur saisie dans la balise, sans comprendre pourquoi.

    Notons au passage les points positifs. Les récentes modifications (éditeur latex, accès aux dernières interventions, hébergement d’images) ont nettement amélioré le confort d’utilisation !

    Merci Thierry


  • Modérateurs

    Merci de me signaler tous les bugs possibles qui me permettront d'améliorer le système.

    Je viens de découvrir cette discussion où mathtous tu reproches au mathforeur de mettre des petits carrés ...

    Il faut savoir que les caractères spéciaux que j'ai placé sous le cadre de saisie (√²³×÷ etc) ne sont tous correctement interprétés par Internet Explorer qui les remplace par des petits carrés.

    Pour ma part, j'utilise Firefox qui lit correctement tous les symboles que j'ai mis à disposition.



  • Bonjour,

    S'il s'agit de codes en MathML, avec Internet Explorer il me semble qu'il est nécessaire d'installer MathPlayer,
    gratuit ICI.

    PS : Je n'ai pas testé.


  • Modérateurs

    Il ne s'agit pas de MathML mais tout simplement de symboles html que l'on pourrait taper mais qui sont plus pratiques à utiliser avec les boutons que j'ai placé sous la fenêtre de saisie.



  • Ah d'accord ! Très pratique en effet ces boutons. Je retiens que l'on peut utiliser tous les
    symboles html ♠ ‰ ⊕ ≅ ∠

    Il y a peut-être une police ou autre à installer pour qu'ils soient lisibles avec IE. Firefox supporte tout ça par défaut.

    Bonne soirée.


Se connecter pour répondre