Algorithme



  • Bonsoir !

    J'ai un exercice avec un algorithme à effectuer. Jusque là, aucun problème :

    Variables

    • N est du type nombre
    • S est du type nombre

    Début Algorithme

    • Lire N
    • Si (N<=30) alors
      -- Debut si
      -- S prend la valeur 0.12*N
      -- Fin si
    • Si (N>30 et N<=60) alors
      -- Début si
      -- S prend la valeur 3.60+0.10*(N-30)
      -- Fin si
    • Si (N>60 et N<=100) alors
      -- Début si
      -- S prend la valeur 6.60+0.8*(N-60)
      -- Fin si
    • Si (N>100) alors
      -- Début si
      -- S prend la valeur 9.80+0.06*(N-100)
    • Afficher S
      Fin Algorithme

    Voilà. Maintenant, on doit le transformer en utilisant la structure << Si... alors... sinon... >>. Le problème c'est que je vois pas comment l'utiliser, puisqu'il y a 4 << Si... alors... >>.

    Merci pour votre aide. Et désolé pour le manque de clarté de mon algorithme, je n'ai pas pu faire autrement, je n'ai pas de scanner.


  • Modérateurs

    Bonsoir,

    Tu vas écrire quatre fois
    Si
    alors
    Sinon
    Si
    .....



  • Merci. Mais que dois-je mettre dans le "Sinon" ?


  • Modérateurs

    Rien,

    apres
    Sinon
    tu écris Si .....


 

Découvre aussi nos cours et fiches méthode par classe

Les cours pour chaque niveau

Encore plus de réponses par ici

Il semble que votre connexion ait été perdue, veuillez patienter pendant que nous vous re-connectons.